CentOS为yum添加官方源
由于centos5.4安装好后通过yum来安装php的版本是5.1.6,现在很多站点都是在5.2.x上开发的,所以我们要添加其他的yum repo
来安装Php5.2.x的版本,测试了几个非官方的repo仓库,感觉代码都不是很稳定,php版本也随时在升级。找了很久,发现centos
官方的一个test repo里面有php5.2.x,安装centos官方的rpm比较放心

1.添加yum repo php5.2.x
vi /etc/yum.repos.d/CentOS-Testing.repo
[c5-testing]
name=CentOS-5 Testing
baseurl=http://dev.centos.org/centos/$releasever/testing/$basearch/
enabled=1
gpgcheck=1
gpgkey=http://dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing
priority=1



2.安装
yum upgrade php


完成!

转载自:http://www.gaojinbo.com/centos-yum-php5-2-x-repo%E5%AE%89%E8%A3%85%E6%96%B9%E6%B3%95.html


最后编辑: Sonic 编辑于2010/03/15 17:25
Tags: ,
游记-风情 | 评论(2) | 引用(0) | 阅读(19452)
Share |
Ansen Email Homepage
2012/04/09 18:55
你好,感谢你的回复但是我不管是使用  yum --enablerepo=c5-testing  list php还是yum upgrade php 出来的都只有5.3,没有5.2
Sonic 回复于 2012/04/10 15:12
啊。原来是这样。看来是文章过时了。我记得当时是想从5.1升到5.2。那时候5.2还处于测试版阶段,所以只能从centos的dev库里取。现在你正好反过来了。看来得找其他办法了。 :)
Ansen Email Homepage
2012/04/06 14:07
貌似不行样我的是centos5.6,照你的方法添加后,没有5.2[root@Ansen ~]# yum --enablerepo=webtatic list phpLoaded plugins: fastestmirrorLoading mirror speeds from cached hostfile * base: centos.ustc.edu.cn * extras: centos.ustc.edu.cn * updates: centos.ustc.edu.cnwebtatic                                                    |  951 B     00:00Installed Packagesphp.i386                           5.1.6-32.el5                           installedAvailable Packagesphp.i386                           5.3.10-1.w5                            webtatic
Sonic 回复于 2012/04/09 18:19
不知道您还会不会回来看回复,已经到您那边发了个回贴了。这点上,blog是没有微博方便。 :)
分页: 1/1 第一页 1 最后页